Centos下删除以及安装ruby

由于jekyll从要求ruby2.0提升到>=2.1故有了这次ruby的删除与重新安装。

1.卸载旧版本

centos或者RHEL安装了老版本ruby的可以直接

$ yum remove ruby -y

来卸载ruby及其依赖包

 

2.安装新版ruby

这里安装ruby2.3.7

下载:

若未安装wget,则
$ yum install -y wget
$ wget https://cache.ruby-lang.org/pub/ruby/2.3/ruby-2.3.7.tar.gz
$ tar -zxvf https://cache.ruby-lang.org/pub/ruby/2.3/ruby-2.3.7.tar.gz
$ cd ruby-2.3.7

编译安装:

$ ./configure
$ make
$ make install

查看是否安装成功:

$ ruby -v
$ ruby 2.3.7

安装成功!

 

发表评论

电子邮件地址不会被公开。 必填项已用*标注